Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004796 [JEDI VCL] 00 JVCL Components minor always 2009-05-28 12:29 2009-09-22 15:37
Reporter a-s-z View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.36
Summary 0004796: TJvDynControlCxPanel ignores BorderStyle
Description When 3RDPARTY_DEVEXPRESS_USE_CXGROUPBOX is active, every panel draws a border regardless of the BorderStyle. The cxGroupBox with PanelStyle=true uses Style.BorderStyle instead of BorderStyle to determine the border style. To mimic the appearance of a Panel, the properties should get synchronized.
Additional Information Add the following override to TjvDynControlCxPanel to resolve the problem:

{$IFDEF 3RDPARTY_DEVEXPRESS_USE_CXGROUPBOX}
procedure TJvDynControlCxPanel.BoundsChanged;
begin
  if BorderStyle = cxcbsNone then
  begin
    if Style.BorderStyle <> ebsNone then
      Style.BorderStyle := ebsNone;
  end
  else
  begin
    if svBorderStyle in Style.AssignedValues then
      Style.AssignedValues := Style.AssignedValues - [ svBorderStyle ];
  end;
end;
{$ENDIF}
Tags No tags attached.
Attached Files ? file icon unit1.dfm [^] (750 bytes) 2009-06-02 16:34
? file icon unit1.pas [^] (640 bytes) 2009-06-02 16:34

- Relationships

-  Notes
(0015534)
jfudickar (developer)
2009-05-30 09:58

Two questions: Which revision of the file did you have? I can't reproduce it.

  UnitVersioning: TUnitVersionInfo = (
    RCSfile: '$URL: https://jvcl.svn.sourceforge.net:443/svnroot/jvcl/trunk/jvcl/run/JvDynControlEngineDevExpCx.pas [^] $';
    Revision: '$Revision: 12286 $';
    Date: '$Date: 2009-04-26 21:29:53 +0200 (So, 26 Apr 2009) $';
    LogPath: 'JVCL\run'
  );


Could you please create a small sample, which shows the problem.

Kind regards
Jens
(0015598)
a-s-z (reporter)
2009-06-02 16:36

Hi,

you have to activate NativeStyle in a LookAndFeelController to see the problem. I have attached a small sample.

my version info:
  UnitVersioning: TUnitVersionInfo = (
    RCSfile: '$URL: https://jvcl.svn.sourceforge.net/svnroot/jvcl/branches/JVCL3_36_PREPARATION/run/JvDynControlEngineDevExpCx.pas [^] $';
    Revision: '$Revision: 12145 $';
    Date: '$Date: 2009-01-13 00:57:23 +0100 (mar., 13 janv. 2009) $';
    LogPath: 'JVCL\run'
  );
(0015599)
jfudickar (developer)
2009-06-02 18:07

I'm not on my development system until next week.

But could you update to the current version of the code. I'm sure that i had made some changes since january.

Kind regards
Jens
(0015727)
jfudickar (developer)
2009-06-28 16:52

Any News?
(0015740)
a-s-z (reporter)
2009-07-02 09:18

Hi,

sorry for the late answer, but I have been busy in the last weeks.

I did not try the current version, but looked at the code. (Is it possible to install another jcl/jvcl version side-by-side without affecting "stable" install?)
I think the default behaviour does not show borders any more, but changes in BorderStyle won't get reflected in Style.BorderStyle.
(0015741)
jfudickar (developer)
2009-07-02 22:13

I've changed the code to this. (Revision 12366)

procedure TJvDynControlCxPanel.ControlSetBorderStyle(Value: TBorderStyle);
begin
  if value = bsNone then
    BorderStyle := cxcbsNone
  else
    BorderStyle := cxcbsDefault;
  if BorderStyle = cxcbsNone then
  begin
    if Style.BorderStyle <> ebsNone then
      Style.BorderStyle := ebsNone;
  end
  else
  begin
    if svBorderStyle in Style.AssignedValues then
      Style.AssignedValues := Style.AssignedValues - [ svBorderStyle ];
  end;
end;


Please try if it solves your problem .

Kind regards
Jens
(0016127)
obones (administrator)
2009-09-22 15:37

No answers, I believe this is fixed

- Issue History
Date Modified Username Field Change
2009-05-28 12:29 a-s-z New Issue
2009-05-29 23:21 jfudickar Assigned To => jfudickar
2009-05-29 23:21 jfudickar Status new => assigned
2009-05-30 09:58 jfudickar Note Added: 0015534
2009-05-30 09:58 jfudickar Status assigned => feedback
2009-06-02 16:34 a-s-z File Added: unit1.dfm
2009-06-02 16:34 a-s-z File Added: unit1.pas
2009-06-02 16:36 a-s-z Note Added: 0015598
2009-06-02 18:07 jfudickar Note Added: 0015599
2009-06-28 16:52 jfudickar Note Added: 0015727
2009-07-02 09:18 a-s-z Note Added: 0015740
2009-07-02 22:13 jfudickar Note Added: 0015741
2009-09-22 15:37 obones Note Added: 0016127
2009-09-22 15:37 obones Status feedback => resolved
2009-09-22 15:37 obones Fixed in Version => Daily / SVN
2009-09-22 15:37 obones Resolution open => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker