Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004816 [JEDI VCL] 00 JVCL Components minor always 2009-06-08 21:15 2009-07-08 14:03
Reporter jkelley View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.34
Summary 0004816: JvCaptionButton draws incorrectly with minimized bsToolWindow
Description JvCaptionButton sets its FHasSmallCaption field to true if BorderStyle is bsToolWindow or bsSizeToolWin, but minimized windows with this style are regular size, causing the buttons to be drawn and placed incorrectly.
Additional Information
Tags No tags attached.
Attached Files zip file icon JvCaptionBug.zip [^] (405,114 bytes) 2009-06-16 19:17
? file icon JvCaptionBug.patch [^] (2,611 bytes) 2009-06-26 03:08

- Relationships

-  Notes
(0015634)
jkelley (reporter)
2009-06-08 21:44

Update: It looks like this is only the case if themes are turned off; with themes on, minimized tool windows still use small buttons.
(0015681)
obones (administrator)
2009-06-16 11:37

Please try with the latest release. If it is still there, please provide the zipped sources of a sample application showing this
(0015690)
jkelley (reporter)
2009-06-16 18:22

I tested against r12301 (the most recent change to JvCaptionButton.pas that doesn't include external dependencies) and against JVCL 3.36, and the problem is still there.

My Delphi install is apparently broken right now. Could you use a C++Builder sample application?

If so, I'll upload one. If not, here are instructions for recreating the problem:
1) Create a new "MDI Application" project.
2) Change ChildWin's FormStyle to fsNormal.
3) Change ChildWin's BorderStyle to bsSizeToolWin.
4) Add a TJvCaptionButton to ChildWin. Set the button's Standard property to something like tsbMin so that you can see what its icon looks like.
5) Make sure that Windows is using the classic look (pre-XP, no themes).
6) Run the app, go under File and pick New to create a new child window, then right-click on the child window's toolbar and choose minimize.
(0015692)
jkelley (reporter)
2009-06-16 19:17

Delphi 2009 sample project attached.
(0015723)
jkelley (reporter)
2009-06-26 03:09

The attached patch seems to fix it. I also undid part of the change in r12301; removing that adjustment was necessary to make JvCaptionButton display properly on my Vista Aero Glass machine, so I'm not sure why the adjustment was added or under what circumstances it's needed.
(0015779)
obones (administrator)
2009-07-08 14:03

This is now fixed in SVN

- Issue History
Date Modified Username Field Change
2009-06-08 21:15 jkelley New Issue
2009-06-08 21:44 jkelley Note Added: 0015634
2009-06-16 11:37 obones Note Added: 0015681
2009-06-16 11:37 obones Status new => feedback
2009-06-16 18:22 jkelley Note Added: 0015690
2009-06-16 19:17 jkelley File Added: JvCaptionBug.zip
2009-06-16 19:17 jkelley Note Added: 0015692
2009-06-26 03:08 jkelley File Added: JvCaptionBug.patch
2009-06-26 03:09 jkelley Note Added: 0015723
2009-07-03 17:29 obones Status feedback => acknowledged
2009-07-08 14:03 obones Note Added: 0015779
2009-07-08 14:03 obones Status acknowledged => resolved
2009-07-08 14:03 obones Fixed in Version => Daily / SVN
2009-07-08 14:03 obones Resolution open => fixed
2009-07-08 14:03 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker