Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004866 [JEDI VCL] 00 JVCL Components feature always 2009-07-18 07:53 2009-08-25 18:50
Reporter Majid View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.36
Summary 0004866: Suggestion for JvXPBar and JvDBLookup
Description Files JvXPBar.pas and JVDBLookup have modified at lines listed below for the correction of RightToLeft feature. Please, do them in your next release if possible.

JvXPBar:
(938, 2192, 2202, 2219, 2232, 2233, 2234)

JvDBLookup:
(2821, 3315, 3327, 3354)
Additional Information
Tags No tags attached.
Attached Files zip file icon JvXPBar_JvDBLookup.zip [^] (35,085 bytes) 2009-07-18 07:53

- Relationships

-  Notes
(0015869)
obones (administrator)
2009-07-21 11:17

What does it provide and what does it try to fix?
Could you send the zipped sources of a sample application showing the benefits?
(0015872)
Majid (reporter)
2009-07-22 08:30

This is a sample.
thanks!
(0015931)
obones (administrator)
2009-08-05 12:20

Thanks.
I'm sorry, but your "fix" is not usable as is because it considers that EVERYONE uses right to left reading. Please propose a patch that takes into account both ways of reading text.
(0015979)
Majid (reporter)
2009-08-11 12:17

JvDbLoolup not completely show text with BidiMode=bdRightToLeft that is corrected.
I add BidiMode and ParentBidiMode properties to JvXpBar and correct Its code and now support both LeftToRight and RightToLeft BidiMode. Please see the sample.
Thanks.
(0015991)
obones (administrator)
2009-08-13 14:13

Thanks, this is now in SVN
(0016013)
AHUser (developer)
2009-08-25 18:50

Deleted attachments that contained Induct.A virus.

- Issue History
Date Modified Username Field Change
2009-07-18 07:53 Majid New Issue
2009-07-18 07:53 Majid File Added: JvXPBar_JvDBLookup.zip
2009-07-18 07:54 Majid Issue Monitored: Majid
2009-07-21 11:17 obones Note Added: 0015869
2009-07-21 11:17 obones Status new => feedback
2009-07-22 08:30 Majid Note Added: 0015872
2009-07-22 08:33 Majid File Added: Sample.zip
2009-08-05 12:20 obones Note Added: 0015931
2009-08-11 12:17 Majid Note Added: 0015979
2009-08-11 12:18 Majid File Added: New_Sample.zip
2009-08-13 14:13 obones Note Added: 0015991
2009-08-13 14:13 obones Status feedback => resolved
2009-08-13 14:13 obones Fixed in Version => Daily / SVN
2009-08-13 14:13 obones Resolution open => fixed
2009-08-13 14:13 obones Assigned To => obones
2009-08-25 18:49 AHUser Status resolved => feedback
2009-08-25 18:49 AHUser Resolution fixed => reopened
2009-08-25 18:49 AHUser File Deleted: Sample.zip
2009-08-25 18:49 AHUser File Deleted: New_Sample.zip
2009-08-25 18:50 AHUser Note Added: 0016013
2009-08-25 18:50 AHUser Status feedback => resolved
2009-08-25 18:50 AHUser Resolution reopened => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker