Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004898 [JEDI VCL] 00 JVCL Components major always 2009-08-14 11:14 2009-08-14 12:14
Reporter ahesse View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004898: TJvDirectoryEdit.PopupDropDown lost call for BrowseForFolder if DialogKind is dkWin32
Description The last refactoring with removing of {$ifdef CLR} code remove some code with {$ifndef CLR}.
So this component loses some sourcecode to call BrowseForFolder if DialogKind is dkWin32.

Additional Information Fix: revert the changes here from the last refactoring
...
    if NewStyleControls and (DialogKind = dkWin32) then
      Action := BrowseForFolder(FDialogText, sdAllowCreate in DialogOptions, Temp, Self.HelpContext)
    else
...
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0015999)
ahesse (reporter)
2009-08-14 11:32

Already solved, Duplicate of 0004893
(0016000)
obones (administrator)
2009-08-14 12:14

This has already been fixed in SVN

- Issue History
Date Modified Username Field Change
2009-08-14 11:14 ahesse New Issue
2009-08-14 11:32 ahesse Note Added: 0015999
2009-08-14 12:14 obones Note Added: 0016000
2009-08-14 12:14 obones Status new => resolved
2009-08-14 12:14 obones Fixed in Version => Daily / SVN
2009-08-14 12:14 obones Resolution open => fixed
2009-08-14 12:14 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker