Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004946 [JEDI VCL] 00 JVCL Components block always 2009-09-18 16:57 2009-09-20 02:02
Reporter INFOTECH View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004946: TJvDBCalcEdit - External exception C0FB007F
Description RAD Studio 2010 Ent. and JVCL 3.38
This error occours only if "Enable runtine themes" of the Delphi project is active, not only at runtime but also in the ide, when a from than contains a TJvCalcEdit or TJvDBCalcEdit component is shown.
At design time is enough to drop a JvCalcEdit component on a form to reproduce the problem.
In this case the repetition of the message blocks the ide.
No problem at runtime if you don't use Runtime Themes.
When error occours you can see the the icon of the JvCalcEdit component is not designed.

Other nformations about this error message in this page:
http://blog.delphi-jedi.net/2009/08/29/version-checking-for-delphi/ [^]

But at the moment I can workaround this problem only removing the component.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0004925resolvedAHUser [TJVComboEdit, TJVDBComboEdit] - External Exception 

-  Notes
(0016112)
AHUser (developer)
2009-09-20 01:56

Already fixed in SVN. An updated JvThemes.pas fixes the bug.
(0016113)
AHUser (developer)
2009-09-20 02:02

More "information" about this bug:
http://andy.jgknet.de/blog/?p=660 [^]

- Issue History
Date Modified Username Field Change
2009-09-18 16:57 INFOTECH New Issue
2009-09-20 01:56 AHUser Relationship added duplicate of 0004925
2009-09-20 01:56 AHUser Note Added: 0016112
2009-09-20 01:56 AHUser Status new => resolved
2009-09-20 01:56 AHUser Fixed in Version => Daily / SVN
2009-09-20 01:56 AHUser Resolution open => fixed
2009-09-20 01:56 AHUser Assigned To => AHUser
2009-09-20 02:02 AHUser Note Added: 0016113
2009-09-20 02:02 AHUser Status resolved => feedback
2009-09-20 02:02 AHUser Resolution fixed => reopened
2009-09-20 02:02 AHUser Status feedback => resolved
2009-09-20 02:02 AHUser Resolution reopened => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker