Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005007 [JEDI VCL] 00 JVCL Components feature N/A 2009-11-04 20:49 2012-09-10 14:15
Reporter tetardd View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005007: TJvListView: add an OnBeginColumnResize, OnColumnResize, OnEndColumnResize events
Description TJvListView:

Add the above mentioned events as described in:

http://thomasfreudenberg.com/blog/archive/2004/03/14/HDN-TRACK.aspx [^]
http://www.swissdelphicenter.ch/torry/showcode.php?id=1264 [^]

Note: The OnBeginColumnResize should have a "Var CanResize : Boolean" param that can be used to prevent that column resizing (see http://www.swissdelphicenter.ch/torry/showcode.php?id=2133). [^]

Additional Information
Tags No tags attached.
Attached Files zip file icon ImprovedJvListView.zip [^] (423,317 bytes) 2009-11-08 10:56

- Relationships

-  Notes
(0016863)
tetardd (reporter)
2009-11-08 11:02

Included is my attempt at doing it. It seems to be working perfectly.
You'll find a test unit called ImprovedJvListView where I simply created a descendant of TJvListView for testing the proposed changes, and, a small app to demonstrate it works.
Then, you'll find my proposed additions already included in the SVN version of JvListView.pas unit, all my changes in that unit marked "DT".

Note:
1- I could not resist the temptation in one place to clarify the code by renaming a variable ("Index" which is very unclear into "ColumnIndex" which is much clearer).

2- I also added one small other functionality that I could not find and that would be useful: a variable that indicates which colum is currently sorted. This way, we can save that value, for example in the registry then restore it when re-launching an application. It's called FSortedColumnIndex".
(0016934)
obones (administrator)
2009-12-04 14:47

Thanks for this, it will be reviewed and acted upon when we have more time
(0019583)
obones (administrator)
2012-02-27 15:29

This is now in SVN

- Issue History
Date Modified Username Field Change
2009-11-04 20:49 tetardd New Issue
2009-11-08 10:56 tetardd File Added: ImprovedJvListView.zip
2009-11-08 11:02 tetardd Note Added: 0016863
2009-12-04 14:47 obones Note Added: 0016934
2009-12-04 14:47 obones Status new => acknowledged
2012-02-27 15:29 obones Note Added: 0019583
2012-02-27 15:29 obones Status acknowledged => resolved
2012-02-27 15:29 obones Fixed in Version => Daily / SVN
2012-02-27 15:29 obones Resolution open => fixed
2012-02-27 15:29 obones Assigned To => obones
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker