Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005052 [JEDI VCL] 00 JVCL Components major always 2009-12-09 19:57 2013-12-13 11:21
Reporter abbe2003cz View Status public  
Assigned To obones
Priority normal Resolution suspended  
Status resolved   Product Version 3.36
Summary 0005052: TJvDBGrid handles OnKeyPress event twice
Description A TJvDBGrid handles an OnKeyPress() event twice. One time correctly, one time with var Key equal to #0.
Notice: "dgEditing" in "Options" must be set to "true".
Additional Information   begin
>>>> inherited; <<<<< ...ist it necessary? (line 2720)

    if Assigned(FCurrentControl) then
    begin
      if FCurrentControl.Visible then
        PostMessage(FCurrentControl.Handle, WM_CHAR, Msg.CharCode, Msg.KeyData);
    end
    else
      if InplaceEditor = nil then
        DoKeyPress(Msg); // This is needed to trigger an onKeyPressed event when the
                         // default editor hasn't been created because the data type
                         // of the selected field is binary or memo.
  end;
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0016989)
wpostma416 (developer)
2009-12-11 17:32

from the user saying "Notice: "dgEditing" in "Options" must be set to "true". " I get the idea that this "twice" bug might be a conflict between the JVCL component and the changes in the base VCL class in Delphi 2010.

In other words, this bug probably isn't a bug, until we hit Delphi 2010, which as one of its not-so-bright moves, changed how grid header click handling works. Introducing the breaking change "dgEditing" into Options. (It's on by default in all projects to which you add a DBGrid, but off whenever an existing Delphi 2009 or earlier project is imported.)

A change that is {$ifdefd for delphi 2010} and higher is probably likely to be needed here.
(0019587)
obones (administrator)
2012-02-27 16:10

The sources of a demo application would be really nice to have here
(0019834)
obones (administrator)
2012-06-11 17:13

Any news?
(0020765)
obones (administrator)
2013-12-13 11:21

No news, suspending the issue

- Issue History
Date Modified Username Field Change
2009-12-09 19:57 abbe2003cz New Issue
2009-12-11 17:32 wpostma416 Note Added: 0016989
2009-12-18 12:05 obones Status new => acknowledged
2009-12-18 12:05 obones Target Version => Daily / SVN
2012-02-27 16:10 obones Note Added: 0019587
2012-02-27 16:10 obones Status acknowledged => feedback
2012-06-11 17:13 obones Note Added: 0019834
2013-12-13 11:21 obones Note Added: 0020765
2013-12-13 11:21 obones Status feedback => resolved
2013-12-13 11:21 obones Resolution open => suspended
2013-12-13 11:21 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker