Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005191 [JEDI VCL] 00 JVCL Components major always 2010-03-10 17:53 2011-06-10 16:09
Reporter prmas View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.39
Summary 0005191: TJvDBDateTimePicker not update data
Description Hi:

When the property "kind" is equal to "tdkTime" the component does not update the data.

Analyzing the file JvDBDateTimePicker.pas found a condition that prevented the update on line 505.

In the procedure "TJvDBDateTimePicker.UpdateData" the condition "if IsDateAndTimeField then" is wrong because it only works for DateTime fields. In my case the field is Time.

I disabled the condition and worked perfectly.

Follow the attached file with the fix.

Best regards,

Marcos
Additional Information
Tags No tags attached.
Attached Files ? file icon JvDBDateTimePicker.pas [^] (19,243 bytes) 2010-03-10 17:53

- Relationships

-  Notes
(0017348)
AHUser (developer)
2010-04-02 13:57

Fixed in SVN.

- Issue History
Date Modified Username Field Change
2010-03-10 17:53 prmas New Issue
2010-03-10 17:53 prmas File Added: JvDBDateTimePicker.pas
2010-04-02 13:57 AHUser Note Added: 0017348
2010-04-02 13:57 AHUser Status new => resolved
2010-04-02 13:57 AHUser Fixed in Version => Daily / SVN
2010-04-02 13:57 AHUser Resolution open => fixed
2010-04-02 13:57 AHUser Assigned To => AHUser
2011-06-10 16:09 obones Fixed in Version Daily / SVN => 3.40


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker