Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005235 [JEDI VCL] 00 JVCL Components minor always 2010-05-11 11:13 2011-06-10 16:10
Reporter Thor View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005235: TjvDbComboBox disappear in runtime when autosize is true
Description I've just noticed that in my program, some field using TjvDbComboBox are
missing in runtime. In design time it's all ok, there is the component with
datasource set / datafield set / items set / values set / enabled=True / enableValues = True / visible = True
but in runtime when i open the form, this DbComboBox is missing !
After some researching i've found that the problem is the autosize property.
If it's set to true the DbComboBox is going "invisible" ;-)
I've solved setting the autosize to false so i set the "severity" to "minor" for this bug
Additional Information
Tags No tags attached.
Attached Files zip file icon testDBComboBox.zip [^] (573,766 bytes) 2010-06-07 16:54

- Relationships

-  Notes
(0017453)
obones (administrator)
2010-06-07 13:50

Could you please provide the zipped sources of a sample application showing this?
(0017466)
Thor (reporter)
2010-06-07 16:54

here what you have requested ...
(0017468)
AHUser (developer)
2010-06-07 17:42

Fixed by removing the AutoSize property in SVN revision 12796.
It was never meant to be published. TComboBox doesn't support AutoSize and TJvCustomComboBox/TJvDBCustomComboBox do not implement anything new here.

The AutoSize property was (accidentally) added in SVN revision 10699.

- Issue History
Date Modified Username Field Change
2010-05-11 11:13 Thor New Issue
2010-05-11 11:13 Thor Issue Monitored: Thor
2010-06-07 13:50 obones Note Added: 0017453
2010-06-07 13:50 obones Status new => feedback
2010-06-07 16:54 Thor File Added: testDBComboBox.zip
2010-06-07 16:54 Thor Note Added: 0017466
2010-06-07 17:42 AHUser Note Added: 0017468
2010-06-07 17:42 AHUser Status feedback => resolved
2010-06-07 17:42 AHUser Fixed in Version => Daily / SVN
2010-06-07 17:42 AHUser Resolution open => fixed
2010-06-07 17:42 AHUser Assigned To => AHUser
2010-08-20 08:42 Thor Issue End Monitor: Thor
2011-06-10 16:10 obones Fixed in Version Daily / SVN => 3.40


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker