Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005395 [JEDI VCL] 00 JVCL Components tweak N/A 2010-11-09 00:20 2012-02-29 16:53
Reporter masonwheeler View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0005395: Exposing conversion routines in TJvxSlider
Description Something I ran into recently.

I had a TjvxSlider with several marks on it, representing a range of percentages. In order to keep track of where 100 and other values are, I used a handful of TLabels. They're easy enough to position correctly in the form designer, but if the form gets resized, I need a way to keep the labels lined up with the marks they correspond to.

I was able to add an OnResize event, but it was difficult calculating the right positions. I figured there had to be a way to calculate the position of a mark, since the control knows where to put them, so I looked and found the GetOffsetByValue method. Unfortunately, it and its reciprocal, GetValueByOffset, aren't public.

Moving them to the public section solved my problems easily. Since this is a simple calculation that doesn't change any internal state, there's no risk involved in exposing these methods.

Submitting my changes as per the MPL.
Additional Information
Tags No tags attached.
Attached Files ? file icon jvxSlider.diff [^] (1,114 bytes) 2010-11-09 00:20

- Relationships

-  Notes
(0018043)
obones (administrator)
2010-11-09 14:29

Thanks, this is now in SVN

- Issue History
Date Modified Username Field Change
2010-11-09 00:20 masonwheeler New Issue
2010-11-09 00:20 masonwheeler File Added: jvxSlider.diff
2010-11-09 14:29 obones Note Added: 0018043
2010-11-09 14:29 obones Status new => resolved
2010-11-09 14:29 obones Fixed in Version => Daily / SVN
2010-11-09 14:29 obones Resolution open => fixed
2010-11-09 14:29 obones Assigned To => obones
2012-02-29 16:53 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker