Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005726 [JEDI VCL] 04 Feature Request major always 2011-11-29 08:46 2012-09-10 14:15
Reporter RHoek View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.40
Summary 0005726: Missing old Rx 'OnDropDown' and 'OnCloseup' events
Description When using TJvCustomComboEdit descendants I'm was missing the old equivalent of the OnDropDown and OnCloseUp events.

I did found the new events OnPopupShown and OnPopupHidden, but these are not published (which they were in the RxLib).

Can this be implemented (properties made published!) for the inherited components like 'TJvCalcEdit'?
Additional Information
Tags No tags attached.
Attached Files zip file icon Test JVCL OnPopupShown+OnPopupHidden.zip [^] (90,176 bytes) 2012-02-22 17:14
zip file icon Modiefied units.zip [^] (54,594 bytes) 2012-04-03 14:11
zip file icon DEMO App.zip [^] (86,900 bytes) 2012-04-03 14:13

- Relationships

-  Notes
(0019153)
RHoek (reporter)
2011-11-29 08:47

Example for TJvCalcEdit:


  TJvCalcEdit = class(TJvCustomCalcEdit)
  published
    property BevelEdges;
    property BevelInner;
    property BevelKind default bkNone;
    property BevelOuter;
    property BiDiMode;
    property DragCursor;
    property DragKind;
    property Flat;
    property ParentBiDiMode;
    property ParentFlat;
    property ImeMode;
    property ImeName;
    property OnEndDock;
    property OnStartDock;
    property Action;
    property Align; //Polaris
    property Alignment;
    property AutoSelect;
    property AutoSize;
    property BeepOnError;
    property BorderStyle;
    property ButtonFlat;
    property ButtonHint;
    property CheckOnExit;
    property ClickKey;
    property Color;
    property DecimalPlaceRound; //Polaris
    property DecimalPlaces;
    property DirectInput;
    property DisplayFormat;
    property DragMode;
    property Enabled;
    property EnablePopupChange;
    property Font;
    property FormatOnEditing;
    property Glyph;
    property ImageIndex;
    property Images;
    property ImageKind;
    property ButtonWidth;
    property HideSelection;
    property Anchors;
    property Constraints;
    property MaxLength;
    property MaxValue;
    property MinValue;
    property NumGlyphs;
    property ParentColor;
    property ParentFont;
    property ParentShowHint;
    property PopupAlign;
    property PopupMenu;
    property ReadOnly;
    property ShowButton;
    property ShowHint;
    property TabOrder;
    property TabStop;
    property Text;
    property Value;
    property Visible;
    property ZeroEmpty;
    (* ++ RDB ++ *)
    property ClipboardCommands;
    property DisabledTextColor;
    property DisabledColor;
    (* -- RDB -- *)
    property DecimalPlacesAlwaysShown; {WAP Added.}
    property OnButtonClick;
    property OnChange;
    property OnClick;
    property OnDblClick;
    property OnDragDrop;
    property OnDragOver;
    property OnEndDrag;
    property OnEnter;
    property OnExit;
    property OnKeyDown;
    property OnKeyPress;
    property OnKeyUp;
    property OnMouseDown;
    property OnMouseMove;
    property OnMouseUp;
    property OnContextPopup;
    property OnStartDrag;
    property OnPopupHidden; // RH: Added - issue 5726
    property OnPopupShown; // RH: Added - issue 5726
  end;
(0019154)
RHoek (reporter)
2011-11-29 08:49

Hmmm, when looking at the Rx code, I found out I was missing these in Rx to and added them myself....

If possible I'll be glad to add the events myself to the Jedi VCL.
(0019155)
RHoek (reporter)
2011-11-29 09:00

And for TJvDBCalcEdit (left out current code until .......)

  TJvDBCalcEdit = class(TJvCalcEdit)
  published
    .........
    property OnStartDock;
    property OnPopupHidden; // RH: Added - issue 5726
    property OnPopupShown; // RH: Added - issue 5726
    (* ++ RDB ++ *)
    property ClipboardCommands;
    property DisabledTextColor;
    property DisabledColor;
    (* -- RDB -- *)
  end;
(0019157)
Arioch (developer)
2011-11-29 11:51

why have them on TFileEdit, TCalcEdit and other specialised ones ?

they were designed for generic TButtonEdit AFAICT.
(0019159)
RHoek (reporter)
2011-11-29 13:27

I use this in many cases where the 'Enter' key (which is also used as a confirmation of the selected value/calculation) is linked to a action.

The event trigger the ActionManager to 'disable' the 'Enter' key while the popup is shown/dropped down (and when the popup is hidden I enabled the Enter key again).

I've done this for different components. (I've implemented this in 2002 in the Rx lib, because I did not know a nicer way of doing this).

And still I think this is a very nice way.

Typically I use RTTI (Delphi 2007) to set the event at runtime (which requires it to be published). This way I don't need to typecast the controls.

Second I think this would be a nice way for other people to hook into the exact moment the popup is shown/hidden. (In a RAD way - not needing to create a new component)
(0019416)
RHoek (reporter)
2012-02-14 08:32

Any questions?

If you like I can add these Events myself in the code at the needed places?
(0019468)
obones (administrator)
2012-02-22 15:14

Please provide the zipped sources of a sample application showing this
Please also provide a patch file to apply the changes
(0019478)
RHoek (reporter)
2012-02-22 17:14

I've added a DEMO project, showing the problem...
(I looking for the time now, to add the modified files)
(0019687)
RHoek (reporter)
2012-04-03 14:14

Uploaded modified unit AND created an new DEMO app (with all controls, that have been modified)
(0019929)
obones (administrator)
2012-06-12 16:28

This is now in SVN

- Issue History
Date Modified Username Field Change
2011-11-29 08:46 RHoek New Issue
2011-11-29 08:47 RHoek Note Added: 0019153
2011-11-29 08:49 RHoek Note Added: 0019154
2011-11-29 09:00 RHoek Note Added: 0019155
2011-11-29 11:51 Arioch Note Added: 0019157
2011-11-29 13:27 RHoek Note Added: 0019159
2012-02-14 08:32 RHoek Note Added: 0019416
2012-02-22 15:14 obones Note Added: 0019468
2012-02-22 15:14 obones Status new => feedback
2012-02-22 17:14 RHoek File Added: Test JVCL OnPopupShown+OnPopupHidden.zip
2012-02-22 17:14 RHoek Note Added: 0019478
2012-04-03 14:11 RHoek File Added: Modiefied units.zip
2012-04-03 14:13 RHoek File Added: DEMO App.zip
2012-04-03 14:14 RHoek Note Added: 0019687
2012-06-11 17:40 obones Status feedback => acknowledged
2012-06-12 16:28 obones Note Added: 0019929
2012-06-12 16:28 obones Status acknowledged => resolved
2012-06-12 16:28 obones Fixed in Version => Daily / SVN
2012-06-12 16:28 obones Resolution open => fixed
2012-06-12 16:28 obones Assigned To => obones
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker