Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005759 [JEDI VCL] 00 JVCL Components major always 2012-01-03 15:44 2012-09-10 14:15
Reporter ZENsan View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005759: Cell hint is shown in wrong position
Description When ShowCellHint = True hint is shown always in the top left point of the cell and not at the mouse cursor position.

Why it is performed this way?
    if not AtCursorPosition and HintWindowClass.ClassNameIs('THintWindow') then
      HintPos := ClientToScreen(CursorRect.TopLeft);
Why not Mouse.CursorPos?

I think hint must drop down where is mouse cursor andnot in the another side of the screen (if cell is bigger than 16 pixels...).
Additional Information
Tags No tags attached.
Attached Files ? file icon JvDBGrid.pas.patch [^] (391 bytes) 2012-01-06 09:02
png file icon Hint.png [^] (22,875 bytes) 2012-02-22 15:45
zip file icon HintIssue.zip [^] (1,560 bytes) 2012-02-22 15:45
? file icon Property solution - JvDBGrid.pas.patch [^] (2,685 bytes) 2012-03-07 07:36

- Relationships

-  Notes
(0019299)
ZENsan (reporter)
2012-01-05 08:15

I forgot to tell.. :) It's JvDBGrid.pas, sorry.
(0019316)
ZENsan (reporter)
2012-01-16 09:18

Hello!
Is there someone alive? :) Just check a patch and apply it if it is correct.
(0019393)
ZENsan (reporter)
2012-02-12 15:15

Or probably we can invent a property (bicycle :) ) for defining how hint is displayed - below mouse cursor or in the top-left corner of grid. I just checked how it is in DC++ (RevConnect) software - they display the hint in top-left corner.
So maybe a property like:
  TJvGridCellHintPosition = (chpDefault, chpMouse);
And then in appropriate place we select how to display the hint.
(0019464)
obones (administrator)
2012-02-22 15:10

Please provide the zipped sources of a sample application showing this
(0019475)
ZENsan (reporter)
2012-02-22 15:46

When you move mouse over the right corner of the first cell, hint is popped up at top left corner. Which maybe is a default of course, but sometimes is very weird.
Just read my comment about possible property..
(0019480)
Arioch (developer)
2012-02-22 21:54

Truly, i disliek how most GUI libraries tend to use Mouse.Pos.

Win32 plain API was much more correct here.

For many times i saw some application frozen for a second or two, and then menu or hint popped up at completely different place (since mouse moved suring those seconds)

I would also say that there are large cursorls, like those by Stardock CursorFX, so that hints "under cursor" got really hidden by that very cursor.
I do not know if complete and reliable solution can be made in frames of VCL, but it is not just so easy...

Regarding this particular case, i suspect the goal of hint was not just to react to mouse, but to show the complete cell value, when it is too narrow to render the whole text. Cell may display like "abcd...xyz" while the hint would render the hole alphabet. From this POV following mouse cursor is not that obvious choice.
(0019481)
ZENsan (reporter)
2012-02-23 07:22

That's why I suggested the property for that choice. And by default make it as it was before.
(0019651)
ZENsan (reporter)
2012-03-07 07:37

I uploaded "Property solution - JvDBGrid.pas.patch". There I added a published property named CellHintPosition of type TJvDBGridCellHintPosition (gchpDefault, gchpMouse), by default it is as it was before. But now if you set to gchpMouse then hint appears under mouse cursor.
(0019912)
obones (administrator)
2012-06-12 13:40

Thanks, this is now in SVN

- Issue History
Date Modified Username Field Change
2012-01-03 15:44 ZENsan New Issue
2012-01-05 08:15 ZENsan Note Added: 0019299
2012-01-06 09:02 ZENsan File Added: JvDBGrid.pas.patch
2012-01-16 09:18 ZENsan Note Added: 0019316
2012-02-12 15:15 ZENsan Note Added: 0019393
2012-02-22 15:10 obones Note Added: 0019464
2012-02-22 15:10 obones Status new => feedback
2012-02-22 15:45 ZENsan File Added: Hint.png
2012-02-22 15:45 ZENsan File Added: HintIssue.zip
2012-02-22 15:46 ZENsan Note Added: 0019475
2012-02-22 21:54 Arioch Note Added: 0019480
2012-02-23 07:22 ZENsan Note Added: 0019481
2012-03-07 07:36 ZENsan File Added: Property solution - JvDBGrid.pas.patch
2012-03-07 07:37 ZENsan Note Added: 0019651
2012-06-11 17:15 obones Status feedback => acknowledged
2012-06-12 13:40 obones Note Added: 0019912
2012-06-12 13:40 obones Status acknowledged => resolved
2012-06-12 13:40 obones Fixed in Version => Daily / SVN
2012-06-12 13:40 obones Resolution open => fixed
2012-06-12 13:40 obones Assigned To => obones
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker