Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005827 [JEDI VCL] 00 JVCL Components major always 2012-03-09 21:55 2012-09-10 14:15
Reporter chickenrudi View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005827: TJvSimpleXML: XMLData gives unreadable characters
Description When I try to display the data from TJvSimpleXML by reading it's contents from the property XMLData or the method SaveToString I just get some kind of "chinese" characters. This wasn't always so.

If I save the content from this component to a TStringStream I can eventually use the property DataString to display the xml content.

Attached is a very simple project that should help you to understand what I mean.

Ruediger
Additional Information Delphi 2010
Windows 7 (64)
Tags No tags attached.
Attached Files zip file icon SimpleXMLTest.zip [^] (1,811 bytes) 2012-03-09 21:55

- Relationships

-  Notes
(0019656)
AHUser (developer)
2012-03-10 19:49

This should be fixed with svn revision 3768.

The problem was that a unicode TStringStream was written to from a TJclAnsiString. So the SaveToStream() method wrote the XML as AnsiString into the stream (1 byte per char) and the SaveToString/SaveToStringEncoding() method read it as a UnicodeString (2 byte per char).
(0019658)
chickenrudi (reporter)
2012-03-10 21:31

Thank you, everything works fine again.

- Issue History
Date Modified Username Field Change
2012-03-09 21:55 chickenrudi New Issue
2012-03-09 21:55 chickenrudi File Added: SimpleXMLTest.zip
2012-03-10 19:49 AHUser Note Added: 0019656
2012-03-10 19:49 AHUser Assigned To => AHUser
2012-03-10 19:49 AHUser Status new => feedback
2012-03-10 21:31 chickenrudi Note Added: 0019658
2012-03-11 20:20 AHUser Status feedback => resolved
2012-03-11 20:20 AHUser Fixed in Version => Daily / SVN
2012-03-11 20:20 AHUser Resolution open => fixed
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker