Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005998 [JEDI VCL] 00 JVCL Components minor always 2012-10-03 08:12 2012-10-03 12:11
Reporter kmz7 View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005998: Border of some edit controls (with buttons) disappears when VCL Styles used (XE3)
Description Some Edit controls (e.g. with buttons inside) has issues with VCL Styles enabled. Border missing when form shown, it appears on mouse move, and disappears on enter. Part of left border destroyed by text background on control exit.
RAD Studio XE3 used.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020240)
AHUser (developer)
2012-10-03 11:10

Do those "some edit control" have a class name?
(0020241)
kmz7 (reporter)
2012-10-03 11:24

All with button inside... TJvDirectoryEdit, TJvFilenameEdit, TJvCalcEdit, etc... And TJvMaskEdit too. Looks like all Edits inheriting TJvCustomComboEdit... It has same glitch.
(0020242)
AHUser (developer)
2012-10-03 12:10

Well, this is another bug in the VCL's Style engine which paints edits smaller than they are. You get a one pixel extra left, top, right and bottom border. And that causes the interior rectangle to paint over the now wrongly painted edit border. Even the button isn't placed correctly anymore.

Wordaround added to svn revision 13451.

- Issue History
Date Modified Username Field Change
2012-10-03 08:12 kmz7 New Issue
2012-10-03 11:10 AHUser Note Added: 0020240
2012-10-03 11:24 kmz7 Note Added: 0020241
2012-10-03 12:10 AHUser Note Added: 0020242
2012-10-03 12:11 AHUser Status new => resolved
2012-10-03 12:11 AHUser Resolution open => fixed
2012-10-03 12:11 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker