Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006018 [JEDI VCL] 00 JVCL Components major always 2012-10-24 03:01 2015-09-14 13:20
Reporter Barry Andrews View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.46
Summary 0006018: FindText has conflict with Windows FindText for C++ builder 2010
Description When trying to use the TJvRichEdit->FindText function under C++ Builder XE2 you will get a linker error saying that it cannot fint TJvCustomRichEdit::FindTextA this is due to a conflict with the Windows find text function.

It is possible this same conflict exists in other JVCL components
Additional Information In order to get around this I had to add into user supplied area
at the top of the TJvRichEdit.hpp file.

//-- user supplied -----------------------------------------------------------
#define FindText TJvCustomRichEdit::FindText

Then changed typedef which had a parameter named FindText

typedef void __fastcall (__closure *TRichEditFindErrorEvent)(System::TObject* Sender, const System::UnicodeString FindText);

to

typedef void __fastcall (__closure *TRichEditFindErrorEvent)(System::TObject* Sender, const System::UnicodeString FoundText);


Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020367)
obones (administrator)
2013-01-15 15:48

Changed it to TextToFind as it really is that

- Issue History
Date Modified Username Field Change
2012-10-24 03:01 Barry Andrews New Issue
2013-01-15 15:48 obones Note Added: 0020367
2013-01-15 15:48 obones Status new => resolved
2013-01-15 15:48 obones Fixed in Version => Daily / SVN
2013-01-15 15:48 obones Resolution open => fixed
2013-01-15 15:48 obones Assigned To => obones
2015-09-14 13:20 obones Fixed in Version Daily / GIT => 3.48


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker