Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006093 [JEDI VCL] 00 JVCL Components tweak always 2013-02-26 17:28 2015-09-14 13:20
Reporter moore View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0006093: TJvImageList has no straightforward way to add images
Description Double clicking does not open the ImageList Editor as in the starndard TImageList component.

What I do for now is create a TImageList, fill it with images and then convert it in the dfm to the TJvImageList component to use this latter's features..
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020496)
AHUser (developer)
2013-05-25 13:40

I cannot reproduce this. In XE3 the IDE's default ImageList editor opens if I double click on a TJvImageList.
(0020539)
moore (reporter)
2013-06-25 12:42

I have JVCL3-2013-05-29 installed with XE2, i double click and it opens the event handler OnChange in the code editor..

I wish someone else could confirm this in XE2.
(0020555)
Omfalos (reporter)
2013-07-04 19:58

I confirm, in XE2 does not work. But when i install on XE2 only with update 1 was ok. After update to fix update 4 on this same XE2 stop working.
(0020558)
AHUser (developer)
2013-07-05 23:28

I can't reproduce this with "RAD Studio XE2 Update 4 Hotfix 1"

Do you have the "Hotfix 1" installed?
(0020559)
Omfalos (reporter)
2013-07-06 12:06

Yes, i have now "hotfix 1" and TJvImageList does not work correctly now.
(0020560)
AHUser (developer)
2013-07-07 19:11

> does not work correctly now

"Does work correctly now" or "Does not work correctly" ?
(0020695)
Omfalos (reporter)
2013-11-21 23:27

Does not work.
(0020699)
AHUser (developer)
2013-12-01 11:06

Fixed in master branch.

It works if the you enable the "Register global designtime editors" in the installer what I did except for XE5 where I can now reproduce this bug.

The fix is to register the JVCL's TJvImageListEditor component editor explicitly for TJvImageList.

- Issue History
Date Modified Username Field Change
2013-02-26 17:28 moore New Issue
2013-05-25 13:40 AHUser Note Added: 0020496
2013-05-25 13:40 AHUser Status new => feedback
2013-06-25 12:42 moore Note Added: 0020539
2013-07-04 19:58 Omfalos Note Added: 0020555
2013-07-05 23:28 AHUser Note Added: 0020558
2013-07-06 12:06 Omfalos Note Added: 0020559
2013-07-07 19:11 AHUser Note Added: 0020560
2013-11-21 23:27 Omfalos Note Added: 0020695
2013-12-01 11:06 AHUser Note Added: 0020699
2013-12-01 11:06 AHUser Status feedback => resolved
2013-12-01 11:06 AHUser Fixed in Version => Daily / SVN
2013-12-01 11:06 AHUser Resolution open => fixed
2013-12-01 11:06 AHUser Assigned To => AHUser
2015-09-14 13:20 obones Fixed in Version Daily / GIT => 3.48


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker