Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006130 [JEDI VCL] 00 JVCL Components crash always 2013-04-17 10:23 2015-09-14 13:20
Reporter dougwoodrow View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.47
Summary 0006130: Property ExplicitWidth does not exist when using Delphi 7
Description Discovered after rebuilding a Delphi 7 application that calls TJvLogFile.ShowLog() - it throws the following error:

"Error reading ToolBar1.ExplicitWidth: Property ExplicitWidth does not exist."

So the problem is in JvLogForm.dfm, but a quick scan shows new Explicit* properties in several forms.
Additional Information Same problem as "Sourceforge bug 1484149 property ExplicitWidth does not exist when using Delphi 7. Reported by kirdape." mentioned on
http://jedicodeformat.sourceforge.net/Jcf2changes.html [^]

DDevExtensions has an Explicit* property remover to keep DFM files compatible with older Delphi versions:
http://andy.jgknet.de/blog/ide-tools/ddevextensions/ [^]
Tags Delphi 7.0
Attached Files

- Relationships

-  Notes
(0020504)
AHUser (developer)
2013-05-25 14:51

Fixed in svn revision 13518.

- Issue History
Date Modified Username Field Change
2013-04-17 10:23 dougwoodrow New Issue
2013-04-21 10:24 dougwoodrow Tag Attached: Delphi 7.0
2013-05-25 14:51 AHUser Note Added: 0020504
2013-05-25 14:51 AHUser Status new => resolved
2013-05-25 14:51 AHUser Fixed in Version => Daily / SVN
2013-05-25 14:51 AHUser Resolution open => fixed
2013-05-25 14:51 AHUser Assigned To => AHUser
2015-09-14 13:20 obones Fixed in Version Daily / GIT => 3.48


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker