Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006226 [JEDI VCL] 00 JVCL Components crash always 2013-11-18 16:28 2015-09-14 13:20
Reporter sebbien View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0006226: TJvComboBox.Add raises Access Violation when CharCase<>ecNormal
Description If I put CharCase=ecUpperCase, then the first addition of an item to the combobox will raise an access violation, other additions are running ok.

Severity : causes Acces Violation, this is the problematic part
and it was working in Delphi 2010 (old version of JVCL), so it's hard to find when migrating to XE4/XE5
otherwise, its easily workaroundable.

version displayed in about box of delphi for JVCL is 3.48
Additional Information
Tags No tags attached.
Attached Files zip file icon TJvComboBoxBugReport.zip [^] (4,355 bytes) 2013-11-18 16:28

- Relationships

-  Notes
(0020698)
AHUser (developer)
2013-12-01 10:39

Fixed in master branch.

The problem is this:
<quote>
Comclt32.dll version 5.0 or later: If CBS_LOWERCASE or CBS_UPPERCASE is set, the Unicode version of CB_ADDSTRING alters the string. If using read-only global memory, this causes the application to fail.
</quote>

A string literal is read only, so "cb.Add('abc')" causes a access violation while "cb.Add('ab' + S)" doesn't. The fix is to call UniqueString on the specified string.

- Issue History
Date Modified Username Field Change
2013-11-18 16:28 sebbien New Issue
2013-11-18 16:28 sebbien File Added: TJvComboBoxBugReport.zip
2013-12-01 10:39 AHUser Note Added: 0020698
2013-12-01 10:39 AHUser Status new => resolved
2013-12-01 10:39 AHUser Fixed in Version => Daily / SVN
2013-12-01 10:39 AHUser Resolution open => fixed
2013-12-01 10:39 AHUser Assigned To => AHUser
2015-09-14 13:20 obones Fixed in Version Daily / GIT => 3.48


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker