Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006296 [JEDI VCL] 02 Installation minor have not tried 2014-06-02 20:06 2015-09-21 17:47
Reporter neva View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.47
Summary 0006296: Installation failure with JVCL348CompleteJCL26-Build5178.zip
Description Installed the JCL from the expanded zip file OK - no errors.
Installed the JVCL using install.bat and the installation program. got the following:
C:\Program Files (x86)\Borland\JVLC348\jvcl\run\JvRichEdit.pas(6013) Error: Undeclared identifier: 'DWORD_PTR'
C:\Program Files (x86)\Borland\JVLC348\jvcl\run\JvRichEdit.pas(6065) Error: Undeclared identifier: 'DWORD_PTR'
C:\Program Files (x86)\Borland\JVLC348\jvcl\run\JvDynControlEngineJVCL.pas(47) Fatal: Could not compile used unit '..\..\run\JvRichEdit.pas'
When loading delphi7 it tells me it cannot find JVGIFAnimator and TJVScrolltext - since I wanted any upgrade to the animator component this is annoying

The download was JVCL348CompleteJCL26-Build5178.zip


What do I download? Maybe a different version?
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020993)
AHUser (developer)
2014-06-03 16:49

This old Delphi version incompatibility was fixed a month ago.

You can download a daily snapshot that contains the fix:
JCL: http://jcl.sourceforge.net/daily/ [^]
JVCL: http://jvcl.sourceforge.net/daily/ [^]

- Issue History
Date Modified Username Field Change
2014-06-02 20:07 neva New Issue
2014-06-03 16:49 AHUser Note Added: 0020993
2014-06-03 16:49 AHUser Status new => resolved
2014-06-03 16:49 AHUser Fixed in Version => Daily / GIT
2014-06-03 16:49 AHUser Resolution open => fixed
2014-06-03 16:49 AHUser Assigned To => AHUser
2015-09-21 17:47 obones Fixed in Version Daily / GIT => 3.49


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker