Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006305 [JEDI VCL] 00 JVCL Components block always 2014-07-17 23:24 2014-09-03 11:40
Reporter MikeVTaos View Status public  
Assigned To obones
Priority normal Resolution no change required  
Status resolved   Product Version 3.47
Summary 0006305: Problems with JvGIF in JVCLCustomDontrols in Delphi XE6 Update 1
Description Upon start of Delphi XE6 Update 1 IDE having JVCL 3.48, the following error is displayed:

[Window Title]
Error

[Content]
Can't load package C:\Users\Public\Documents\Embarcadero\Studio\14.0\Bpl\JvStdCtrlsDesign200.bpl.
The specified procedure could not be found.
Do you want to attempt to load this package the next time a project is loaded?

[Yes] [No]

This occurs despite the fact that the BPL file does exist there along with all the others.

I'm not sure if the following was related because I was originally dealing with a problem with a different 3rd-party lib not being re-installed by the Delphi XE6 Update 1 process, but I'm listing it here because I think it was also related to the
Additional Information Also, when an app is opened the first time in an IDE session, and a form is opened that contains a standard Delphi TImage component that specifies a PNG file in its Picture property, the property is cleared out in the Object Inspector and the component does not show the image in the IDE or at run-time. However, a glance at the DFM makes it look like an image is still there.

Since the VCL form did not actually use any JVCL components, I removed the JvGIF entry from the uses clause and removed the JVCL Custom Controls package and this additional problem disappeared.
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0021035)
obones (administrator)
2014-09-03 11:40

This is an installation issue, most likely because you have different conflicting versions of the JVCL on your computer

- Issue History
Date Modified Username Field Change
2014-07-17 23:24 MikeVTaos New Issue
2014-07-28 05:47 PeterG Issue Monitored: PeterG
2014-09-03 11:40 obones Note Added: 0021035
2014-09-03 11:40 obones Status new => resolved
2014-09-03 11:40 obones Resolution open => no change required
2014-09-03 11:40 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker