Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006316 [JEDI VCL] 03 Donations feature always 2014-08-19 18:28 2015-09-21 17:47
Reporter vintagedave View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.47
Summary 0006316: Add area graphs to TJvChart
Description An area graph is a line graph with the area under the line filled in (like this: http://www.qualia.hr/wp-content/uploads/2011/11/area.jpg [^] )

I have written a small patch to add this to TJvChart, filling the area under the line with a color between the line color and page color.

The main problem with this kind of chart is when lines overlap - does the background hide the underlying graph? In this implementation I draw the backgrounds first and lines second, so even if a line dips behind another line, it will still be visible. (More advanced would be to alpha-blend the filled areas, but...)

Rather than adding another chart type (eg area chart) it is an option "FillUnderLine" property that's used when drawing line charts, and is off by default.

I also (I know I should put this as another issue, sorry) made a tweak so when the axis width is 0, it won't draw (otherwise it draws a 1px line) and ditto for the rectangle around the whole graph. This is to give a more modern, minimal look without lines everywhere.
Additional Information I have attached a patch against the latest downloadable version of the JVCL.
Tags No tags attached.
Attached Files ? file icon jvchart fill patch.patch [^] (9,317 bytes) 2014-08-19 18:28
zip file icon JvChart filled demo.zip [^] (27,332 bytes) 2014-09-08 15:46
png file icon JvChart filled demo - screenshot.png [^] (24,710 bytes) 2014-09-08 15:47

- Relationships

-  Notes
(0021039)
obones (administrator)
2014-09-03 11:42

Please provide the zipped sources of a sample application showing this
(0021057)
vintagedave (reporter)
2014-09-08 15:47

Done. I've attached a sample project and a screenshot of what it looks like.
(0021071)
vintagedave (reporter)
2014-11-13 13:54

Any feedback on this? It's been in status "feedback" for two / three months. I added the demo app and screenshot as requested, but I haven't got permissions to change the status to indicate something was done.
(0021090)
obones (administrator)
2014-12-04 16:21

This is now in GIT

- Issue History
Date Modified Username Field Change
2014-08-19 18:28 vintagedave New Issue
2014-08-19 18:28 vintagedave File Added: jvchart fill patch.patch
2014-09-03 11:42 obones Note Added: 0021039
2014-09-03 11:42 obones Status new => feedback
2014-09-08 15:46 vintagedave File Added: JvChart filled demo.zip
2014-09-08 15:47 vintagedave File Added: JvChart filled demo - screenshot.png
2014-09-08 15:47 vintagedave Note Added: 0021057
2014-11-13 13:54 vintagedave Note Added: 0021071
2014-12-04 15:04 obones Status feedback => acknowledged
2014-12-04 16:21 obones Note Added: 0021090
2014-12-04 16:21 obones Status acknowledged => resolved
2014-12-04 16:21 obones Fixed in Version => Daily / GIT
2014-12-04 16:21 obones Resolution open => fixed
2014-12-04 16:21 obones Assigned To => obones
2015-09-21 17:47 obones Fixed in Version Daily / GIT => 3.49


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker