Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006389 [JEDI VCL] 00 JVCL Components crash always 2015-03-11 00:41 2015-09-21 17:47
Reporter btt View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.47
Summary 0006389: JvGroupBox crashes when checkable, unchecked and navigating with shift+tab
Description Given a JvGroupBox that has the checkable property enabled and the checked property False, navigating with the keyboard forwards (TAB) is fine. Navigating backwards (SHIFT+TAB) will crash when entering the groupbox.
Additional Information The pas file just has the basic boilerplate:

unit JvGroupBoxCrash;

interface

uses
  Winapi.Windows, Winapi.Messages, System.SysUtils, System.Variants, System.Classes, Vcl.Graphics,
  Vcl.Controls, Vcl.Forms, Vcl.Dialogs, Vcl.StdCtrls, JvExStdCtrls, JvGroupBox;

type
  TForm1 = class(TForm)
    JvGroupBox1: TJvGroupBox;
    Edit1: TEdit;
    Edit2: TEdit;
    Button1: TButton;
    Button2: TButton;
    Button3: TButton;
  private
    { Private declarations }
  public
    { Public declarations }
  end;

var
  Form1: TForm1;

implementation

{$R *.dfm}

end.
Tags No tags attached.
Attached Files ? file icon JvGroupBoxCrash.dfm [^] (1,313 bytes) 2015-03-11 00:41

- Relationships

-  Notes
(0021148)
AHUser (developer)
2015-03-11 19:37

Fixed. The problem was the code in TJvCheckBox.SetFocus that redirected the focus what caused an endless recursion.

- Issue History
Date Modified Username Field Change
2015-03-11 00:41 btt New Issue
2015-03-11 00:41 btt File Added: JvGroupBoxCrash.dfm
2015-03-11 19:37 AHUser Note Added: 0021148
2015-03-11 19:37 AHUser Status new => resolved
2015-03-11 19:37 AHUser Fixed in Version => Daily / GIT
2015-03-11 19:37 AHUser Resolution open => fixed
2015-03-11 19:37 AHUser Assigned To => AHUser
2015-09-21 17:47 obones Fixed in Version Daily / GIT => 3.49


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker