Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006497 [JEDI VCL] 00 JVCL Components feature always 2016-02-24 15:06 2019-04-30 16:15
Reporter dbedrenko View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0006497: Make TJvValidateEdit.Value return Cardinal for dfHex
Description The type returned by the `TJvValidateEdit.Value` property depends on the chosen `TJvValidateEdit.DisplayFormat`.

I have some `TJvValidateEdit` elements with `DisplayFormat: dfHex` in which the user can enter a number that fits in a `Cardinal`, e.g. $FFFFFFFF. The problem is that in `TJvCustomValidateEdit.GetValue()`:

    dfHex:
      Result := StrToIntDef('$' + FEditText, 0);

You don't need to worry about supporting negative numbers because `dfHex` prevents the minus sign ("-") being entered.

Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0021493)
obones (administrator)
2018-07-18 15:44

Is this a feature request? If yes, please provide a pull request at Github containing the required changes
(0021775)
mh (reporter)
2019-04-28 11:07

Pull request created:
https://github.com/project-jedi/jvcl/pull/109 [^]

- Issue History
Date Modified Username Field Change
2016-02-24 15:07 dbedrenko New Issue
2016-02-24 15:08 dbedrenko Issue Monitored: dbedrenko
2018-07-18 15:44 obones Note Added: 0021493
2018-07-18 15:44 obones Status new => feedback
2019-04-28 11:07 mh Note Added: 0021775
2019-04-30 16:15 obones Status feedback => resolved
2019-04-30 16:15 obones Fixed in Version => Daily / GIT
2019-04-30 16:15 obones Resolution open => fixed
2019-04-30 16:15 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker