View Issue Details

IDProjectCategoryView StatusLast Update
0002336JEDI VCL02 Installationpublic2004-11-26 01:05
ReporteranonymousAssigned ToAHUser 
Status resolvedResolutionfixed 
Product Version3.00 BETA 2 
Target VersionFixed in Version3.00 RC 1 
Summary0002336: Doesnt detect delphi 2k5.
DescriptionFor some reason it doesnt detect my version of delphi 2005 to install.
Additional InformationMost of my other components have compiled up on d7 settings, Im thinking JCL/JVCL will too, however, at the moment the nice installer doesnt detect d2k5.

The trial is not sufficient to install either, as it doesnt have the commandline compilers. So would need precompiled stuff :(
TagsNo tags attached.



2004-11-24 10:37

developer   ~0005697

I do not have D2k, yet. And so I cannot make the required changes to the installer.
The installer will never support a trial version because of the missing command line compiler.


2004-11-24 13:12

reporter   ~0005698

I realised this, but I wanted to point it out just in case. As Im finding that Im struggling to get the jvcl to compile with packages anyway.


2004-11-24 22:54

reporter   ~0005699

Got my copy of 2k5 yesterday, haven't tried installing JVCL yet (haven't tried much at all actually). What does the JVCL installer need to know, is it something that we can dig out and then give you the information so that you can add support for it?

I will look into the code of the installer this evening (10 hours from now) and see what I can do.


2004-11-25 03:03

developer   ~0005700

Last edited: 2004-11-25 03:05

At the moment the Installer (CVS) should detect BDS 3.0 and so it meight work, but it is not tested because with the trial version it is impossible to test the dcc32.exe calls.
And the installer requires an installed JCL 1.93 (CVS) what prevents me from debugging the installer downt the dcc32.exe calls.

bearbeitet am: 11-25-04 03:05


2004-11-25 05:22

viewer   ~0005701

The latest cvs detects the d2k5, but isnt seeing the jcl on it, and the jcl installer doesnt detect the d2k5 either.


2004-11-25 05:31

developer   ~0005702

The JCL installer is not my part ;-)

I'm currently working on the installer. After installing the JCL by hand it found out that the JVCL installer detects the D2k as C++Builder version. And further more the Borland Project Group file (.bpg) has been changed to an xml file .bdsgroup which the JVCL installer ignores at the moment so no JVCL packages are available in the Installer's package selection list.


2004-11-25 05:40

viewer   ~0005703

I installed the jcl by hand too, but the jvcl installer didnt detect it :(


2004-11-25 08:54

developer   ~0005705

You must add the jcl\source;jcl\source\common;jcl\source\windows directories to the library path list in Tools/Options. That is what the installer normally does. After that the updated JVCL installer detects the JCL (by finding jcl\source\common\JvBase.pas)

I have committed a new version of installer that should work. But I was not able to test the compile process because there is no dcc32.exe shipped with D2k Trial.


2004-11-26 01:05

developer   ~0005717

JVCL Installer now detects D2k.

Issue History

Date Modified Username Field Change
2004-11-24 07:30 anonymous New Issue
2004-11-24 10:37 AHUser Note Added: 0005697
2004-11-24 13:12 bugfinder Note Added: 0005698
2004-11-24 22:54 mattis000102 Note Added: 0005699
2004-11-25 03:03 AHUser Note Added: 0005700
2004-11-25 03:05 AHUser Note Edited: 0005700
2004-11-25 05:22 anonymous Note Added: 0005701
2004-11-25 05:31 AHUser Note Added: 0005702
2004-11-25 05:40 anonymous Note Added: 0005703
2004-11-25 08:54 AHUser Note Added: 0005705
2004-11-26 01:05 AHUser Status new => resolved
2004-11-26 01:05 AHUser Resolution open => fixed
2004-11-26 01:05 AHUser Assigned To => AHUser
2004-11-26 01:05 AHUser Note Added: 0005717