View Issue Details

IDProjectCategoryView StatusLast Update
0003463JEDI VCL00 JVCL Componentspublic2006-04-05 06:45
Reporterultima_butt_headAssigned Toobones 
Status resolvedResolutionunable to reproduce 
Product Version3.10 
Target VersionFixed in Version 
Summary0003463: Access Violation in All Packages BDS 2006
DescriptionInstallation worked. Got 7 deprecated warnings during JVCL installation. Used the build flag. When I start any of the IDE's I get access violations in the Jv packages. When I start a project I get the same problem. When I click through th e hundreds of violations. Only the JvDBUI are shown in the tools. I even deselected the warning packages, DB and Interpreter, but warnings should just let you continue. After I installed JCL I still can start BDS. After JVCL I suddenly can't.

I reinstalled the JVCL and JCL a few times and even reinstalled BDS a few times. Tried numerous scenarios. And still no luck. I'm in a jam here. Please help.
Additional InformationSystem:
 Windows Server 2003 R2 Enterprise
 Borland Developer Studio 2006 Architect Update 0000001
  Delphi Win32
  Delphi .NET
 JVCL 3.10
 JCL 1.96
 JVCL 3.10 2006-01-23
 JCL 1.96 2006-01-23
TagsNo tags attached.



2006-01-24 01:42

developer   ~0008434

Does the AV also happen if you only load the JvCore.bpl ?


2006-01-24 05:15

reporter   ~0008440

doesn't matter every package including core gives a violation


2006-01-24 05:18

reporter   ~0008441

atm i'm installing borland 2005 if that doesn't resolve the problem. i'm going to install a previous windows 2003. to see if that solves the problem.


2006-01-24 05:53

reporter   ~0008442

i feel so violated!!! Same ol same with BDS 2005. Violation after violation. I think it's the Windows 2003 R2 time to reinstall the workstation :(.


2006-01-24 08:27

reporter   ~0008444

Update: I reinstalled with the Original Windows Server 2003 release. Everything worked perfect, the IDE's started without problems. Then I installed servicepack 1. And a few packages gave an access violation. Primarily the core and forms from JVCL. After the project has started and I try to move JVCL components onto the form, it gives an access violation. Logical because all components rely on the core package. So the problem happens after I installed SP1.


2006-01-24 08:46

reporter   ~0008445

I recompiled the JCL and JVCL and it got worse, all packages now give an access violation :)


2006-01-24 10:13

developer   ~0008446

Have disabled UNITVERSIONING ? If not, disable it. Maybe this fixes the problem.


2006-01-24 12:08

reporter   ~0008447

Last edited: 2006-01-24 12:09

Didn't turn it on. Tried numerous different flags.


2006-01-24 12:56

developer   ~0008448

Can you debug the JvCore package for us?

1. Close BDS 2006.

2. Start BDS 2006 with "bds.exe -pDelphi -rDebug"
This creates a new Delphi configuration in the HKLM\Software\Borland\Debug registry key, without any 3rd party packages like JCL/JVCL.

3. Open the jvcl3\Packages\D10\JvCoreD10R.dpk package in this Delphi instance.

4. Open the "Project options..." dialog and tick all the debug options (except the "only definitions") in the compiler options page.

5. Set the unit search path in the Directories/Conditions page to "..\..\common;..\..\resources"

6. Open the Start/Parameter... dialog and set the host application to "$(BDS)\Bin\bds.exe" and the parameters to "-pDelphi" (start only Delphi personality [faster then loading all personalities]).

7. "Run" the package.


2006-01-24 13:02

reporter   ~0008449

Last edited: 2006-01-24 13:25

Ofcourse I will, but let me first ghost my system. Before I have to reinstall it again ;). I'll have to run the production system in a VM from now on, till the issue is fixed maybe. Make that tommorow, I'm too pooped to do anything (=.=)


2006-01-26 15:03

reporter   ~0008468

Last edited: 2006-01-26 15:08

I did what you said. It gave the following messages.

[Pascal Error] E1026 File not found: 'JvConsts.res'
[Pascal Error] E1026 File not found: 'JvPoweredBy.res'

Anything else I should do?

Running it on a VM now to avoid compromising the rest of my system.


2006-01-26 16:31

developer   ~0008469

Last edited: 2006-01-26 16:31

You forgot point 5.

5. Set the unit search path in the Directories/Conditions page to "..\..\common;..\..\resources"


2006-02-14 06:38

reporter   ~0008550

Win2003 server enterprise, SP1
D2006 Upd1

I tried the above (debugging it under BDS). It gives no error itself, but the problem persists when trying to load the packages.


2006-02-14 06:56

developer   ~0008551

This meight be a problem with the "Data-Execution Prevention" option. JVCL is said to not work with an enabled DEP.


2006-02-14 12:56

developer   ~0008554

Seems none of developers has AMD64 machine yet.
So big help would be from anyone haveing it to send as much debug info as possible.

Perhaps we should try to discuss this issue in nntp-forum ?

Does the bug appears if DEP is turned of in Control Panel / System applet ?

Can this exception be caught and tracked using JCL Debug Exception dialog ?
If to ass {$O-} into and remove any possible {$O+}, then turn generating MAP files on, then add D:\Borland\AddOns\JCL\experts\debug\dialog\ExceptDlg.pas into uses of some unit in design-time JvCore package - would it show stack tracing and so on ?


2006-02-15 10:19

reporter   ~0008562

The DEP-thing did the trick! I changed it to only look for Windows system/services files and now there is no problem in installing the JVCL!

I have AMD an opteron - is there anything I can do to help?


2006-02-19 05:06

developer   ~0008570

Please, perticipate in forum, where this is discussed


2006-04-05 06:44

administrator   ~0008979

I'm closing this issue for the time being. Please use the very latest version, and should the issue come up again, please discuss it on the news groups as Arioch indicated.

Issue History

Date Modified Username Field Change
2006-01-23 20:59 ultima_butt_head New Issue
2006-01-24 01:42 AHUser Note Added: 0008434
2006-01-24 01:42 AHUser Status new => feedback
2006-01-24 05:15 ultima_butt_head Note Added: 0008440
2006-01-24 05:18 ultima_butt_head Note Added: 0008441
2006-01-24 05:53 ultima_butt_head Note Added: 0008442
2006-01-24 08:27 ultima_butt_head Note Added: 0008444
2006-01-24 08:46 ultima_butt_head Note Added: 0008445
2006-01-24 10:13 AHUser Note Added: 0008446
2006-01-24 12:08 ultima_butt_head Note Added: 0008447
2006-01-24 12:09 ultima_butt_head Note Edited: 0008447
2006-01-24 12:56 AHUser Note Added: 0008448
2006-01-24 13:02 ultima_butt_head Note Added: 0008449
2006-01-24 13:25 ultima_butt_head Note Edited: 0008449
2006-01-26 15:03 ultima_butt_head Note Added: 0008468
2006-01-26 15:06 ultima_butt_head Note Edited: 0008468
2006-01-26 15:08 ultima_butt_head Note Edited: 0008468
2006-01-26 16:31 AHUser Note Added: 0008469
2006-01-26 16:31 AHUser Note Edited: 0008469
2006-02-14 06:38 PD Note Added: 0008550
2006-02-14 06:56 AHUser Note Added: 0008551
2006-02-14 12:56 Arioch Note Added: 0008554
2006-02-15 10:19 PD Note Added: 0008562
2006-02-19 05:06 Arioch Note Added: 0008570
2006-04-05 06:44 obones Status feedback => resolved
2006-04-05 06:44 obones Resolution open => unable to reproduce
2006-04-05 06:44 obones Assigned To => obones
2006-04-05 06:44 obones Note Added: 0008979