View Issue Details

IDProjectCategoryView StatusLast Update
0004599JEDI VCL00 JVCL Componentspublic2008-12-22 05:54
ReporterProzacAssigned Toobones 
Status resolvedResolutionfixed 
PlatformWindowsOSVista SP1OS VersionUltimate 64-bit
Product VersionDaily / GIT 
Target VersionFixed in Version3.36 
Summary0004599: JVCL installer destroys
DescriptionAfter updating JCL and JVCL from the SVN I successfully recompiled jcl and then tried to recompile JVCL.
I used Install.bat, I saw CMD generating language files and then the installer has been destroyed. No window has been displayed at all.
TagsNo tags attached.



2008-11-20 13:22

developer   ~0015040

What Delphi version do you use?


2008-11-20 23:40

developer   ~0015045

I'm seeing the same thing with a dual install of Delphi 2007 and Delphi 2009. Note that JVCLInstall.exe is correctly built in jvcl\bin but it is not executed after compilation (through install.bat). Executing JVCLInstall.exe manually works though.


2008-11-21 00:02

administrator   ~0015046

Don't you have an error message?


2008-11-21 01:14

reporter   ~0015048

No error messages here.
After the CMD window disappears something (probably the main installer window) blinks for a split second and disappears.


2008-11-21 02:04

administrator   ~0015049

and if you run install from an cmd window, don't you have a message in the cmd window that does not close anymore?


2008-11-21 06:17

reporter   ~0015050

Hi Olivier!

Well, I've just tried to run Install.bat from CMD.
I got the following info in the commnad line window:

[Compiling installer...]
Using CodeGear RAD Studio 2009

CodeGear Delphi for Win32 compiler version 20.0
Copyright (c) 1983,2008 CodeGear
166514 lines, 1.01 seconds, 1228884 bytes code, 56

[Generating language files...]
Known languages: bg de es fr it nl pl ro ru sv

[Starting installer...]
"The requested operation requires elevation".


2008-11-21 06:47

administrator   ~0015051

Well, there you have it, the batch requires you to be an administrator in Vista.


2008-11-21 07:25

reporter   ~0015053

Yeah. And I am the only one user and the administrator of my own PC.
In such cases the Vista UAC always displays a warning that requires a user's permission. But here I don't see any dialog. So I suppose something is wrong with the installer.


2008-11-21 10:30

developer   ~0015054

There is the CommCtrlAsInvoker.res that the installer uses to prevent the UAC from identifying the installer as an administrative task. And that seems to fail.

2008-11-21 11:31


VistaUAC.manifest (1,101 bytes)


2008-11-21 11:32

reporter   ~0015055

And why do you want to protect the Installer against UAC identification?

Take a look at my own .manifest resource file attached to this message.


2008-11-24 13:33

developer   ~0015063

Because the JCL and JVCL Installer aren't setups in the way a Office Setup is. They are build machines. And as such they need access to the current user's directories (asInvoker) and not the directories of an Administrator (requireAdministrator).


2008-11-24 13:53

developer   ~0015064

I have now changed install.bat to use the old way to start the JVCL Installer if the JVCLCmdStarter.exe can't start it.

Issue History

Date Modified Username Field Change
2008-11-20 12:50 Prozac New Issue
2008-11-20 13:22 AHUser Note Added: 0015040
2008-11-20 23:40 cycocrew Note Added: 0015045
2008-11-21 00:02 obones Note Added: 0015046
2008-11-21 00:02 obones Status new => feedback
2008-11-21 01:14 Prozac Note Added: 0015048
2008-11-21 02:04 obones Note Added: 0015049
2008-11-21 06:17 Prozac Note Added: 0015050
2008-11-21 06:47 obones Note Added: 0015051
2008-11-21 07:25 Prozac Note Added: 0015053
2008-11-21 10:30 AHUser Note Added: 0015054
2008-11-21 11:31 Prozac File Added: VistaUAC.manifest
2008-11-21 11:32 Prozac Note Added: 0015055
2008-11-24 13:33 AHUser Note Added: 0015063
2008-11-24 13:53 AHUser Note Added: 0015064
2008-12-22 05:54 obones Status feedback => resolved
2008-12-22 05:54 obones Fixed in Version => Daily / SVN
2008-12-22 05:54 obones Resolution open => fixed
2008-12-22 05:54 obones Assigned To => obones