View Issue Details

IDProjectCategoryView StatusLast Update
0000005JEDI Code LibraryJclSysInfopublic2002-07-04 14:04
ReportermthomaAssigned Tomthoma 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0000005: TCpuInfo.Type, TCpuInfo.Name and TCpuInfo.Manufacturer return rubbish when the CPU is a Crusoe. TCpuInfo.Type returns 'Unknown
DescriptionTCpuInfo.Type, TCpuInfo.Name and TCpuInfo.Manufacturer return rubbish when the CPU is a Crusoe. TCpuInfo.Type returns "Unknown".
Additional InformationWe need someone with a crusoe to test.
TagsNo tags attached.
Fixed in revision
IDE version

Activities

pvones

2002-03-04 12:18

administrator   ~0000010

According this posting (http://groups.google.com/groups?hl=en&selm=a5dfdt%24r2t%241%40panorama.wcss.wroc.pl) "GenuineTMx86" or "TransmetaCPU" seems to be VendorIDString for Crusoe.

mthoma

2002-03-04 13:27

administrator   ~0000011

A google search for "GenuineTMx86" showed the following nice reference here as well: http://www.sandpile.org/ia32/cpuid.htm

Issue History

Date Modified Username Field Change