View Issue Details

IDProjectCategoryView StatusLast Update
0006052JEDI VCL00 JVCL Componentspublic2014-12-04 16:34
ReporterAndrewTrohinsAssigned Toobones 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.47 
Target VersionFixed in Version 
Summary0006052: JVMemoryDataSet error 'No data found' with Bookmark
DescriptionIf i use link JvMemoryData->DataSource->JvDBGrid, then
exception 'No data found' generated on the second pass of cycle
for (int i = 0 ; i < iC; i++)
{
  DataSet->Bookmark = grd->SelectedRows->Items[i];
}

The same error like in ticket 0006049.

Example of code:

    DataSet->KeyFieldNames = "ID";
    DataSet->Open();
    const int TestCount = 2;
    for (int i = 0; i < TestCount; i++)
    {
        DataSet->Append();
        DataSet->FieldValues["ID"] = i;
        DataSet->FieldValues["TITLE"] = "Test" + IntToStr(i);
        DataSet->Post();
    }
    DataSet->ApplyChanges();
    grd->SelectAll();
    DataSet->DisableControls();
    int iC = grd->SelectedRows->Count;
    for (int i = 0 ; i < iC; i++)
    {
      DataSet->Bookmark = grd->SelectedRows->Items[i];
      //...
    }
    DataSet->EnableControls();
    DataSet->Close();

Can you help me?
TagsBCB

Relationships

related to 0006041 feedback JvMemoryData SortOnFields don't work 

Activities

2012-12-25 09:07

 

TestJvMemDataSetBookMark.rar (83,545 bytes)

obones

2013-12-18 11:55

administrator   ~0020873

I just tried with the latest GIT content, I cannot reproduce the issue.

obones

2014-12-04 16:34

administrator   ~0021122

Assuming this is fixed

Issue History

Date Modified Username Field Change
2012-12-25 09:07 AndrewTrohins New Issue
2012-12-25 09:07 AndrewTrohins File Added: TestJvMemDataSetBookMark.rar
2013-01-15 16:08 obones Status new => acknowledged
2013-12-13 15:30 obones Relationship added related to 0006041
2013-12-13 15:50 obones Tag Attached: BCB
2013-12-18 11:55 obones Note Added: 0020873
2013-12-18 11:55 obones Status acknowledged => feedback
2014-12-04 16:34 obones Note Added: 0021122
2014-12-04 16:34 obones Status feedback => resolved
2014-12-04 16:34 obones Resolution open => fixed
2014-12-04 16:34 obones Assigned To => obones