View Issue Details

IDProjectCategoryView StatusLast Update
0006132JEDI VCL02 Installationpublic2015-09-14 13:20
ReporterwmeyerAssigned ToAHUser 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.47 
Target VersionFixed in Version3.48 
Summary0006132: JVCL Installer won't build
DescriptionThis is the same error reported in, and resolved. But in 3.47, downloaded two days ago, the problem exists.
Additional InformationInstallation to Delphi XE was attempted. Windows 7 64-bit.
TagsNo tags attached.



2013-04-19 18:50

reporter   ~0020468

It appears that the issue in DXE is that although support for unit types is present, DXE uses Types.pas, not System.Types.pas.


2013-04-19 19:35

reporter   ~0020469

The JCL installer builds with no problem, but in JediGUIInstall.pas, I see this:


{$R *.dfm}

  Types, // inlining of Point
  Windows, Messages,

In the JVCL installer code, however, in GenerateDefines.pas, I see this:

  SysUtils, JclStrings;

It would seem to me that neither of these is as it should be. HAS_UNIT_TYPES is one consideration, but whether the file exists in the version of Delphi is another. While I am not certain, I believe that System.Types made its appearance in DXE2.


2013-05-05 13:15

developer   ~0020472

This was fixed in svn revision 13426 on 2012-09-10.

Issue History

Date Modified Username Field Change
2013-04-19 18:24 wmeyer New Issue
2013-04-19 18:50 wmeyer Note Added: 0020468
2013-04-19 19:35 wmeyer Note Added: 0020469
2013-05-05 13:15 AHUser Note Added: 0020472
2013-05-05 13:15 AHUser Status new => resolved
2013-05-05 13:15 AHUser Fixed in Version => Daily / SVN
2013-05-05 13:15 AHUser Resolution open => fixed
2013-05-05 13:15 AHUser Assigned To => AHUser
2015-09-14 13:20 obones Fixed in Version Daily / GIT => 3.48