View Issue Details

IDProjectCategoryView StatusLast Update
0006524JEDI API & WSC Librarypacket32public2016-08-28 09:10
ReporterlimelectAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
Summary0006524: Delphi 10.1 Berlin free Starter
DescriptionDelphi 10.1 Berlin free Starter

JVCL. Could not use install. It detect ONLY D7 and DXE which i have.
On the other hand tried packages\d24 lots of errors cannot compile.
Tried GETIT no jvcl or jcl.
TagsNo tags attached.



2016-08-26 20:44

developer   ~0021389

The Starter Edition doesn't support command line compiling, what is needed by the JCL and JVCL.


2016-08-27 18:12

reporter   ~0021392

Ok. but then
"On the other hand tried packages\d24 lots of errors cannot compile."
Tried compiling as adding components too many errors.


2016-08-27 20:49

developer   ~0021393

What errors? If it is missing units like all the Database stuff, then it's because the Starter Edition doesn't have those.


2016-08-28 08:56

reporter   ~0021394

JclPackagesD240 is compiled and installed
load D24 Packages.groupproj
compile JvCore240.bpl
[dcc32 Fatal Error] JvCore.dpk(41): E2202 Required package 'Jcl' not found
so change to jcl240
made sure it is C:\Users\Public\Documents\Embarcadero\Studio\18.0\Bpl

Found that in directory DCP do not have ANY jcl DCP
how to fix that?
In components i have jcl


2016-08-28 09:04

reporter   ~0021395

Ok found the problem
The DCP output from jcl
go to d24\win32. copied the dcp files to
dcp directory.


2016-08-28 09:10

reporter   ~0021396

all compiled Except for JvDB

Issue History

Date Modified Username Field Change
2016-08-25 19:34 limelect New Issue
2016-08-26 20:44 AHUser Note Added: 0021389
2016-08-27 18:12 limelect Note Added: 0021392
2016-08-27 20:49 AHUser Note Added: 0021393
2016-08-28 08:56 limelect Note Added: 0021394
2016-08-28 09:04 limelect Note Added: 0021395
2016-08-28 09:10 limelect Note Added: 0021396