View Issue Details

IDProjectCategoryView StatusLast Update
0000009JEDI Code LibraryJclShellpublic2002-05-20 12:18
ReportermthomaAssigned ToAleksey Kudinov 
PrioritynormalSeveritytrivialReproducibilityhave not tried
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000009: Small problem with widepath in pathtopidl and others
DescriptionThis is no bug but maybe you would like to take a look at it

var
...
  WidePath: array [0..MAX_PATH] of WideChar;
begin
...
  MultiByteToWideChar(CP_ACP, MB_PRECOMPOSED, PChar(Path), -1, WidePath, MAX_PATH);
...
 
--> length of array is max_path+1 but in MultiByteToWideChar you specify it as
max_path
=====================================================

as I said before this is no bug but maybe for completeness somebody could change the array definition to
WidePath: array [0..MAX_PATH-1] of WideChar
for a future release (if not already done)
Additional InformationReported by

Name : Hans-Jürgen Stockinger
E-mail : hj.stockinger@stockinger.cc

via email.
TagsNo tags attached.
Fixed in revision
IDE version

Activities

Aleksey Kudinov

2002-03-03 08:02

developer   ~0000009

added two types:

TUnicodePath = array[0..MAX_PATH-1] of WideChar;
TAnsiPath = array[0..MAX_PATH-1] of char;

and replaced all occurenced. Don't expect any compatibility problem since these types are used internally in functions and procedures.

Issue History

Date Modified Username Field Change