Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002746 [JEDI VCL] 00 JVCL Components major always 2005-03-12 04:06 2005-04-12 05:17
Reporter maxis View Status public  
Assigned To
Priority normal Resolution open  
Status closed   Product Version 3.00 BETA 2
Summary 0002746: bugs in JvThumbView & JvThumbView
Description 1) JvThumView don't fire event OnChange correctly. If want to see how changed Selected property you need use OnChange & OnClick together.
2) Don't recieve keyboard focus when mouse click. I use JvThumbView1->SetFocus() in OnClick event handler.
3) Filter property contain not supported extensions (as Gif and other). No FilterIndex property.
4) Not exist method to reread directory when you change filter. Only use
JvThumbView1->Directory = JvThumbView1->Directory;
5) OnGetTitle event never fire in when you use Directory. Only in AddFromFile.
6) I make changes for firing OnChange when you change to directory without filtered graphic files.
7) I think, if you have same parameter list for event OnGetTitle in JvThumbnail and JvThumbView, you can assign handler when you create JvThumbnail. Event should be fire as later as possible because for making new Title I need information about image dimention and other. You should send to event handler only Self and created JvThumbnail with all presetted properties.

In most cases I make some change in .pas file commented as //---max and attach it.
Additional Information
Tags No tags attached.
Attached Files zip file icon Thumbs.zip [^] (13,448 bytes) 2005-03-12 04:06

- Relationships
has duplicate 0002745resolvedobones bugs in JvThumbView & JvThumbView 

-  Notes
(0006934)
obones (administrator)
2005-04-12 05:17

This is a duplicate

- Issue History
Date Modified Username Field Change
2005-03-12 04:06 maxis New Issue
2005-03-12 04:06 maxis File Added: Thumbs.zip
2005-03-14 08:51 jfudickar Relationship added has duplicate 0002745
2005-04-12 05:17 obones Status new => closed
2005-04-12 05:17 obones Note Added: 0006934


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker