Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005678 [JEDI VCL] 02 Installation block always 2011-10-10 22:30 2012-09-10 14:15
Reporter Brian View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005678: JVCL doesn't install for x64
Description The 64-bit part of the install always fails with this message:

JVCL 3.45.0.0

[Generating: Packages]
Generating packages for D16
    Loaded template.dpk
    Loaded template.dproj
    Loaded template.rc
[Compiling: Packages]
[Compiling: JvCore160.bpl]
Embarcadero Delphi for Win64 compiler version 23.0
Copyright (c) 1983,2011 Embarcadero Technologies, Inc.
JvCore.dpk(50) Fatal: E2213 Bad packaged unit format: d:\xe2\lib\Win32\release\rtl.dcp.System - Expected version: 23.0, Windows Unicode(x64) Found version: 23.0, Windows Unicode(x86)
Additional Information
Tags No tags attached.
Attached Files png file icon JVCL_SVN_install.png [^] (52,164 bytes) 2011-10-18 01:38
png file icon 2011-10-18 - 02.08.32 ~ Capture.png [^] (39,033 bytes) 2011-10-18 02:09
png file icon 2011-10-18 - 02.08.41 ~ Capture.png [^] (32,073 bytes) 2011-10-18 02:10
png file icon 2011-10-18 - 19.32.37 ~ Capture.png [^] (16,474 bytes) 2011-10-18 19:41
png file icon 2011-10-18 - 19.32.45 ~ Capture.png [^] (6,122 bytes) 2011-10-18 19:41
png file icon 2011-10-18 - 19.32.51 ~ Capture.png [^] (15,917 bytes) 2011-10-18 19:42
png file icon 2011-10-18 - 19.32.57 ~ Capture.png [^] (7,065 bytes) 2011-10-18 19:42
? file icon demo_fe.exe [^] (3,783,680 bytes) 2011-10-19 12:26

- Relationships

-  Notes
(0019025)
Brian (reporter)
2011-10-10 22:30

Forgot to say, with Delphi XE2 (obvious anyway ;)
(0019031)
Arioch (developer)
2011-10-17 22:43

something wrong with Delphi settings, global or per-project
it mixes 32-bit and 64-bit files into the same folder.

where did u got your files from ?

download daily/SVN package and try it, to me it installed easily.
Ormaybe i just checked and fixed the paths, i do not remember.

From the message "JvCore.dpk(50) Fatal: E2213 Bad packaged unit format: d:\xe2\lib\Win32\release\rtl.dcp.System " it is obvious that win32-folder was searched for pre-compiled files by win64-project. How d'You think, is it correct ?
(0019032)
Brian (reporter)
2011-10-18 00:00

got mine from daily.

Have you tried to compile a 64-bit project using any jvcl components?
(0019033)
Arioch (developer)
2011-10-18 01:38

settings of successful installation SVN checkout into XE2-Upd1
(0019034)
Arioch (developer)
2011-10-18 01:39

that was Eclipse-posted screenshot
r ur settings the same ?
---
not any real project, i am currently deep into 32 bit :-)
(0019035)
Brian (reporter)
2011-10-18 02:10

Only get this in the installer when I pick 64 bit (attached screenshots).
(0019036)
Arioch (developer)
2011-10-18 02:28

i selected both 32 and 64 in installer

also i installed update1 to delphi xe2
(0019037)
Arioch (developer)
2011-10-18 02:32

dunno if it help, but u may try to check Verbose - to see exact issued commands and generating debug DCUs

i attached my install settings, dunno if it makes any difference
(0019040)
Brian (reporter)
2011-10-18 19:43

The thing is, the installer doesn't even show the components to be installed when picking 64bit, as shown in the last 4 screenshots comparing vs 32 bit. Does it really compile well for you?

Try new vcl forms app, add 64bit release, drop a TJvSpeedbutton, try to run.
(0019042)
Arioch (developer)
2011-10-19 12:32
edited on: 2011-10-19 12:40

Would this file suit u ?
It has JvLabel, JvMemo, JvCheckbox and JvFileEditbox
.....

> The thing is, the installer doesn't even show the components to be installed when picking 64bit

1) why do u pick 64 bit insstead of 32-bit plus 64-bit ?
2) do u select Design-time packages only instead of both runtime and designtime packages in installer ? your screenshot is cut off, but u can see the field on one of mine.
3) do u understand difference between designtime and runtime packages ? did u opened packages of any library to read thesources and see the differenes? did u read Delphi documentation about packages, what they intended to be and why they are split to runtime and designtime ones ?
4) in particular, do u understand that designtime packages do NOT contain any components ? while technically possible, it only makes sense for fake components like MCK for KOL. And that questions whether 64-bit components can be compiled and whether they can be installed into IDE are completely different questions.
5) did u read Delphi XE2 "What's New" section? In particular, what is different in 64-bit from 32-bit ? In particular, if 64-bit designtime packages are possible at all ?


> Does it really compile well for you?
there are particular incompatibilities. For example 0005688
but in general it works okay

(0019043)
Arioch (developer)
2011-10-19 12:37

Afterall u are not required to use installer

U can spend some time to learn Delphi ways - manually update search and output paths for IDE settings, manually open and compile all runtime DPK's, then manually open and compile and install all designtime DPK's

That way you'd be in full control of their settings and would simply fix attempt to use 32-bit DCU/DCP files for 64-bit DPK target
(0019044)
Arioch (developer)
2011-10-19 12:42

Or u can open Jedi Installer as a regular application and debug it line by line.
Though its code is more complex to understand, than simple opening and compiling one DPK after another.
(0019086)
Karlheinz (reporter)
2011-11-05 12:12

I have the same problem and can't find the error.
(0019087)
AHUser (developer)
2011-11-05 18:38

The JVCLInstaller has code to protect itself from broken IDE library paths. This is done by calling the compiler with "-U$(BDS)\lib" to make it always the first directory the compiler looks into. Unfortunately this was broken with Delphi XE due to the new directory structure. The unit directory is now $(BDS)\lib\win32\release, but the Installer still adds the $(BDS)\lib. For Delphi XE this doesn't break the Installer (unless you removed the $(BDS)\lib\win32\release directory from your IDE library paths). But with Delphi XE2 there is also the Win64 platform and it now depends on how much your IDE library path is messed up.
I have fixed the Installer for Delphi XE and XE2 (and newer version until the directory structure will be changed again, but then you get an exception that I added).


Fixed in svn revision 13148.

- Issue History
Date Modified Username Field Change
2011-10-10 22:30 Brian New Issue
2011-10-10 22:30 Brian Note Added: 0019025
2011-10-17 22:43 Arioch Note Added: 0019031
2011-10-18 00:00 Brian Note Added: 0019032
2011-10-18 01:38 Arioch File Added: JVCL_SVN_install.png
2011-10-18 01:38 Arioch Note Added: 0019033
2011-10-18 01:39 Arioch Note Added: 0019034
2011-10-18 02:09 Brian File Added: 2011-10-18 - 02.08.32 ~ Capture.png
2011-10-18 02:10 Brian File Added: 2011-10-18 - 02.08.41 ~ Capture.png
2011-10-18 02:10 Brian Note Added: 0019035
2011-10-18 02:28 Arioch Note Added: 0019036
2011-10-18 02:32 Arioch Note Added: 0019037
2011-10-18 02:34 Arioch File Added: JVCLInstall.ini
2011-10-18 19:41 Brian File Added: 2011-10-18 - 19.32.37 ~ Capture.png
2011-10-18 19:41 Brian File Added: 2011-10-18 - 19.32.45 ~ Capture.png
2011-10-18 19:42 Brian File Added: 2011-10-18 - 19.32.51 ~ Capture.png
2011-10-18 19:42 Brian File Added: 2011-10-18 - 19.32.57 ~ Capture.png
2011-10-18 19:43 Brian Note Added: 0019040
2011-10-19 12:26 Arioch File Added: demo_fe.exe
2011-10-19 12:32 Arioch Note Added: 0019042
2011-10-19 12:32 Arioch File Deleted: JVCLInstall.ini
2011-10-19 12:37 Arioch Note Added: 0019043
2011-10-19 12:40 Arioch Note Edited: 0019042
2011-10-19 12:42 Arioch Note Added: 0019044
2011-11-05 12:12 Karlheinz Note Added: 0019086
2011-11-05 18:38 AHUser Note Added: 0019087
2011-11-05 18:38 AHUser Status new => resolved
2011-11-05 18:38 AHUser Fixed in Version => Daily / SVN
2011-11-05 18:38 AHUser Resolution open => fixed
2011-11-05 18:38 AHUser Assigned To => AHUser
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker